HOME ➔ SUPPORT ➔ Community ➔ General CourseLab issues ... Microsoft SLK and published content
Microsoft SLK and published content
  View type:
Hi
Great product - one problem at the moment. Published content 2004 spec scorm cannot be read by SLK. It sees the scorm content as a zipped file only and therefore the content is not read and presented as it should. Any ideas please?

Nigel UK[:confused:]
 
Hi Nigel,
When you say it sees the scorm content as Zipped file, is this when you have uploaded your conten to the shared area? if so that should work as what you should do is assigne the e-learning action by right clicking to it and assigne it to the users, or group you would like to test. I hope this would help as it work fine for me except the submition of results that I am having problem with[;)]
 
 
hello Naim,
it seems that we are having the same problem concerning the submition of results. in fact when i sign in as a teacher to view the students submition im not able to view his answers , all i get is the assignment as if i was taking it!! any ideas on that?? thank u
 
 
Hello Naim,

I've got the same problem as Nigel.
I assigned the e-learning actions as you said, but it doesn't work.
The browser asks me if I want to save the file, when it supposed to appear like the solitaire, online.

Any ideas?
 
 
 
I published a SCORM 2004 package using CourseLab and It works fine for me in SLK running on SharePoint 07.

Did you follow through the right procedure?

1. In your SharePoint library, click on the arrow that appears after you mouseover your SCORM package. Select "Check in" then "E-Learning Actions". (Versioning was turn on, so I had to check in first)

2. Click on "Assign this learning resource to yourself". This will load the "Begin Assignment" page.

3. Click on "Begin Assignment" button. A new window containing your SCORM lesson should pop up.


Note: if you assign to someone else, that person must access the assignment via the My Assignment web part and not the sharepoint library (which will prompt them to save the zip file).

Hope this helps.
 
 
 
 
This is an ongoing problem, and no-one will accept responsibility for sorting it out. Some people say it's a course labs fault, other say it's SLK. I think it's both, this is why:

If you create a scorm 1.2 or 2004 zip file and upload it to SLK, some people experience the opening of zip file (me included) some don't.

There are a few non-elegant fixes that do work, but again not for everyone.

Fix 1: open the zip file before you upload it to SLK, then re-zip it with a third party zipper like winrar or 7-Zip. then upload (this doesn't work for me)

Fix 2: open the zip file with the free scorm editor reload, then create the scorm package with reload, then upload it to slk ( works for me )

both point the finger of blame to courselabs zip architecture, which I believe is Gzip.exe

But if you read other posts some people have it working, so it seams to point the finger of blame to the version of SLK you are using and not courselabs.

WE NEED A DEFINATIVE FIX or a viable workaround. PLEASE courselabs help us out.
 
Just to add to the thread, I have been unable to get SLK to read any of the exported courselab .zip packages. The SLK just treats them as zip files much as Nigel says.
 
 
Which version of SLK is this 1.1 or 1.2?
Is it the 32 or 64 bit version?

I have heard that 1.1 32bit was OK but there were some problems with the compression engine on the 64bit version.
I understand this was resolved on the 1.2 release.
 
 
 
Here is the response from the server provider:

The SLK version we are on is SLK-MLG version, which is the same as the first SLK release which is 1.0.799

Their techies are going to try the assignment on some other portals to see if it is replicated.
 
 
 
 
I didn't look back THAT far on the support fora!! Given the improvements made (well so the development team say) it seems a pity not to be using the newer version, over 12 months of development will have made some differences!!
 
 
 
 
 
Hi Richard
If you are still having problems it might be worth checking with Eric ( Customization of 'Submit Assignment' slide ).
They seem to have SLK running with 2.3 or 2.4 quite happily
 
 
 
I have contacted the people responsible for out learning gateway server and I will reply when I know more.
 
Anyone?

The furthest I have got is that the manifest itself creates problems, when I load the manifest into another editor it throws up a three problems. It is these problems I am finding difficult to solve. So is CourseLab 100% CAM 1.3 compatible? Or is SLK not? Or something else?

Any ideas before I have to abandon this great product?
 
 
Hi Nigel!

Usually SLK imports CourseLab courses without problems, or with some unimportant warnings (not errors). Would you like to send us (support@courselab.com) this manifest file (of course, if it is not confidential). Also please provide us information on SLK version.
 
 
 
I've had the same problem as Nigel - SLK running in the Microsoft Learning Gateway 2007 is not opening the course as a SCORM object, but rather trying to open it as a zip file. Is there a problem with the way Courselab 2.3 produces the manifest file?
 
 
 
 
Had a breakthrough working through the manifest - the courses work fine if I open them in the Reload SCORM package editor, and make sure the pages have the parameter 'Is Visible' set to true (it is left blank when exported from Courselab).

Hope this helps others with the same problem! [:p]
 
 
 
 
 
Is there any chance that this fix could be treated as a bug fix in a future build of 2.4?
 
 
 
 
 
I'm working with Courselab 2.3 and Reload also. I tried loading the test course and a sample course using each of the CourseLab SCORM formats. I always get the error "No <learning-design> element found. I can add it manually if it would work and someone could tell me where to add it. Thanks.
 
 
 
 
 
 
Part of this reply didn't make it due to brackets around learning-design, So this is a repost.
I'm working with Courselab 2.3 and Reload also. I tried loading the test course and a sample course using each of the CourseLab SCORM formats. I always get the error "No learning design element found. I can add it manually if it would work and someone could tell me where to add it. Thanks.
Subject:
Message options
No additional options