HOME ➔ DOWNLOAD ➔ Free CourseLab 2.4
Free CourseLab 2.4

CourseLab v2.4 is distributed under freeware license. It has no time limits, but has some restrictions in comparison with commercial CourseLab 2.7 version.

Minimum system requirements for CourseLab 2.4
  • Microsoft® Windows® 2000/XP/2003/Vista/Windows 7;
  • Microsoft® Internet Explorer 6.0 or higher;
  • 50MB hard drive space.
Minimum requirements for viewing learning modules from CourseLab 2.4
  • Microsoft Windows 98, Me, NT 4.0, 2000, XP, 2003, Vista, Windows 7 (limited support of Microsoft Windows 95 *);
  • Internet Explorer 5.0 (Internet Explorer 5.5 or higher recommended), Mozilla FireFox 1.0 or higher, Netscape 7.2 or higher, Opera 9.1 and higher, Safari (Windows version) 3.0 and higher, Google Chrome 1.0 or higher (non-IE browsers have some restrictions);
  • JavaScript enabled;
  • XML and XMLHTTP support enabled (Microsoft® XML Parser 3.0 or higher recommended for Internet Explorer**).
Why should I register my copy of free CourseLab v2.4?

You will need some ID for installing CourseLab updates and/or optional packs. Instead of generating some crazy letter-numbers sequence we will use your e-mail address as your ID. Information on major and/or critical updates also will be sent to you by e-mail. Of course, we will not sell, rent or lease your personal information to others (read our Privacy statement). So please provide us with your valid e-mail.

Usually server generates and sends e-mail confirmation message immediately after submitting the form. But there could be some delay in external e-mail relays (up to several hours depending on relay's configuration).

Current version CourseLab 2.7 is a commercial product. The download link for trial version of CourseLab v2.7 is located on the main download page.